sysmerge IT

19 мая 2019 г.

Debian: Release file for http://archive.debian.org/debian/dists/jessie-backports/InRelease is expired (invalid since 88d 16h 32min 47s). Updates for this repository will not be applied.

На Debian 8 после переключения на архивный репозиторий ftp.debian.org на archive.debian.org запуск обновления пакетов командой apt-get update может завершиться ошибкой
E: Release file for http://archive.debian.org/debian/dists/jessie-backports/InRelease is expired (invalid since 88d 16h 32min 47s). Updates for this repository will not be applied.
Error executing command, exiting
Для решения этой проблемы apt можно запустить с ключем '' -o Acquire::Check-Valid-Until=false"
apt-get -o Acquire::Check-Valid-Until=false update
Сделать эту опцию перманентной можно так
echo 'Acquire::Check-Valid-Until "0";' > /etc/apt/apt.conf.d/10no-check-valid-until
после чего apt-get update будет работать в штатном режиме.